浏览量: 154 次浏览

树莓派安装kears

2020年2月24日 0 作者 Nie Hen

安装tensorflow

首先需要卸载 numpy

sudo pip3 uninstall numpy

报错

Not uninstalling numpy at /usr/lib/python3/dist-packages, outside environment /usr

但是可以import到
enter description here

原因 :不是使用pip安装的 是apt安装的 使用pip无法卸载

使用apt卸载

sudo apt remove python-numpy

安装TensorFlow 源码安装
tensorflow-1.8.0-cp35-none-linux_armv7l.whl

import tensorflow

结果出现一大堆东西但是能显示版本号

安装 keras

enter description here

安装第二个h5py 出现跟numpy一样的错

无法安装 使用命令

sudo apt-get install python3-h5py
sudo apt-get install python3-scipy

然后直接 pip3 install keras
enter description here

后来运行报错 因为TensorFlow是 1.8的 这样安装keras会默认安装最新版本的
导致不兼容
报错 :ImportError: cannot import name ‘tf_utils’

解决办法 降低 keras版本

pip3 install keras==2.2.0

运行成功!